Results page failing to load
Incident Report for Optimizely.com
Resolved
The incident has now been resolved, results will be current as the processing backlog clears.
Posted Apr 16, 2021 - 06:27 PDT
Investigating
We're currently experiencing an issue that is affecting the ability to load some of the results pages. We are actively investigating this issue.
Posted Apr 16, 2021 - 03:32 PDT