Changes to Audiences and Experiments not correctly being reflected in Optimizely's Dashboard
Incident Report for Optimizely.com
Resolved
This incident has been resolved.
Posted Mar 27, 2020 - 08:31 PDT
Monitoring
We have identified the issue and it has been resolved. We are currently monitoring the status.
Posted Mar 27, 2020 - 07:43 PDT