Intermittent Application Accessibility
Incident Report for Optimizely.com
Resolved
The incident has been resolved and we are currently monitoring our services.
Posted Mar 19, 2020 - 16:52 PDT
Investigating
We are investigating reports of application unavailability. We will post additional updates every 30 minutes or when we have information available. Thank you for your patience.
Posted Mar 19, 2020 - 15:58 PDT