Customers unable to submit support tickets
Incident Report for Optimizely.com
Resolved
Resolved - A fix has been implemented and the incident is now resolved
May 20, 11:12 PDT

Identified - We have identified an issue where customers are unable to submit tickets through the Optimizely Help Center (Support Form). Customers can temporarily reach our support by sending an email to support@optimizely.com
May 20, 09:16 PDT
Posted May 20, 2020 - 07:16 PDT