Degraded performance in Admin Center
Incident Report for Optimizely Service
Resolved
We have resolved an issue with an upstream provider. Regular service has been restored. Thank you for your patience.
Posted Mar 27, 2024 - 12:04 UTC
Investigating
We are currently investigating an issue causing degraded performance with the Admin Center. We will update again shortly with progress toward restoring normal performance.
Posted Mar 27, 2024 - 10:57 UTC
This incident affected: General (Optimizely Admin Center).