We are continuing to work with the third party vendor to get the original number restored. Thank you for your patience.
Posted Jul 22, 2025 - 13:17 UTC
Update
This issue remains ongoing as we continue our efforts with a third party supplier to resolve this. Thank you for your patience.
Posted Jul 14, 2025 - 13:18 UTC
Update
We are continuing to work with a third party vendor to fix the issue with the original number. Please continue to use the alternate numbers provided in the prior posts until we are able to have a solution in place. Thank you for your patience.
Posted Jul 07, 2025 - 14:24 UTC
Identified
As a temporary measure, +46 8 502 450 20 phone number has been commissioned while the Optimizely teams work on restoring services on the original number. Please use this number or any of the other contact numbers provided earlier to contact our support team.
Posted Jun 24, 2025 - 00:50 UTC
Update
We are continuing to investigate this issue and we will provide additional updates as they become available
Posted Jun 21, 2025 - 00:37 UTC
Investigating
We are currently investigating an issue causing the Optimizely Support phone number to be unavailable +46 8 555 827 50.