We are continuing to monitor for any further issues.
Posted Jun 19, 2026 - 22:29 UTC
Monitoring
We have deployed a fix to unblock affected customers and are actively monitoring the system to confirm stability. We are also working with our email vendor (SendGrid) to put a more complete solution in place on their side. Please note: during the period when emails were partially dropped, we do not have a record of which individual recipients successfully received messages. As a result, if you choose to re-run an affected campaign (e.g., by sending it to a new campaign), some recipients may receive duplicate emails. We will provide a further update as monitoring continues.
Posted Jun 19, 2026 - 21:50 UTC
Identified
We have likely identified the root cause as a recent SendGrid change that introduced an incompatibility in header processing. We are sharing our findings with SendGrid and implementing a workaround to restore compatibility.
Posted Jun 19, 2026 - 19:51 UTC
Update
We are still looking into this issue and will provide updates as they become available.
Posted Jun 19, 2026 - 19:02 UTC
Update
We are continuing to investigate this issue. We also have a support thread open with Sendgrid.
Posted Jun 19, 2026 - 12:13 UTC
Investigating
We are investigating an issue causing some email campaign messages to be dropped in the North America region. Some emails are still being delivered. Accounts using email campaigns in the region may be affected. We will update as we learn more.
Posted Jun 17, 2026 - 14:00 UTC
This incident affected: Optimizely Data Platform - NA Region (Campaigns).