Search and Navigation performance issue with EMEA03

Incident Report for Optimizely Service

Resolved

No further difficulty has been observed. This incident is now fully resolved.
Posted Jul 28, 2025 - 20:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2025 - 14:47 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 28, 2025 - 14:13 UTC

Investigating

We are currently investigating issue with Search and Navigation EMEA03.
Posted Jul 28, 2025 - 13:54 UTC
This incident affected: Search and Navigation - EMEA Region (North Europe).