Verification is underway for the maintenance items.
Posted May 12, 2025 - 06:15 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 12, 2025 - 00:00 UTC
Scheduled
Start Time: May 12, 2025 00:00 UTC (8pm May 11 EDT). End Time (Estimated): May 12, 2025 10:00UTC (6am May 12 EDT). Duration: 10 hours
Impact: During the maintenance window, users will be restricted to non-editable access.
Details: We will be performing scheduled maintenance to update our data management strategy. This maintenance is part of our efforts to ensure continued reliability and performance. To ensure the least disruption possible, the maintenance will be performed during Sunday evening (US time) with everything back online by 6am EDT
What You Need to Do: No action is required.
Posted Apr 28, 2025 - 17:12 UTC
This scheduled maintenance affected: Configured Commerce: Product Information Management (PIM) – NA Region.