Data Processing Delays in NA

Incident Report for Optimizely Service

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 14:53 UTC

Update

The data processing delay has been resolved, and processing has returned to normal. Recurring campaigns have been resumed, and continuous campaigns are now running as usual.
Our team is actively monitoring the system to ensure continued stable performance. We will provide a final update once we have confirmed full recovery.
We apologize for any inconvenience this may have caused.
Posted Jun 24, 2026 - 10:25 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 24, 2026 - 09:20 UTC

Monitoring

We have implemented a fix, and data processing has resumed. The accumulated processing delay is now clearing, though it may take some time to fully catch up. Customers may continue to see some lag until the backlog has been processed.
Recurring campaigns in the US region remain temporarily paused. We will resume normal campaign scheduling once the backlog has fully cleared, to ensure no duplicate or double sends occur.
Our team is actively monitoring the recovery, and we will confirm once the system has fully returned to normal. Thank you for your continued patience.
Posted Jun 23, 2026 - 21:00 UTC

Identified

Our team is actively working on a fix to resolve delayed data processing. Customers may continue to experience data processing lag while remediation is underway.
As a precautionary measure, we are temporarily pausing recurring campaigns in the US region to prevent duplicate or double sends while processing catches up. We will resume normal campaign scheduling once processing has fully recovered.
We will provide a further update as soon as we have more information. I appreciate your patience.
Posted Jun 23, 2026 - 18:27 UTC

Investigating

We are currently experiencing data processing delays in the North America region. As a result, continuous campaigns will not run until the processing lag has cleared.
Our team is actively investigating and working to restore normal processing times. We will provide an update as soon as we have more information.
We apologize for any inconvenience and appreciate your patience.
Posted Jun 22, 2026 - 20:30 UTC
This incident affected: Optimizely Data Platform - NA Region (Data Ingestion and Processing, Campaigns).