Optimizely Data Platform - Identity resolution - EMEA

Incident Report for Optimizely Service

Resolved

We have finished the large majority of the planned data operations, all duplicates that were created as a part of the incident were removed and all campaign activity returned to normal. Over the coming weeks, we will be prioritising low-impact data clean-up operations.
Posted Nov 21, 2025 - 16:46 UTC

Update

We expect to complete the data repair operations by Friday, 21 November, in the evening (CET).
Posted Nov 19, 2025 - 09:28 UTC

Update

We anticipate commencing data repair operations on Monday evening (CET). Once we begin, we can provide an estimated completion timeline.
Posted Nov 16, 2025 - 14:52 UTC

Update

We are working on a solution to resolve the remaining data inconsistencies. An estimated completion time will be provided in due course.
Posted Nov 13, 2025 - 22:13 UTC

Update

We have identified all the variations of potential inconsistencies and now working on a solution to resolve them.
Posted Nov 12, 2025 - 22:12 UTC

Update

We're still analysing the affected dataset to identify potential inconsistencies and develop a plan for resolving them.
Posted Nov 11, 2025 - 08:23 UTC

Update

We have successfully recovered identity data for profiles that were seen before the incident. This recovery enables working with the original profiles instead of profile duplicates that may have been created during the incident. We will continue to examine the data to identify potential inconsistencies and develop a plan for resolving them.
Posted Nov 08, 2025 - 08:39 UTC

Update

We are continuing to work with our vendor to test a potential solution for one of the underlying data storage systems.
Posted Nov 08, 2025 - 02:04 UTC

Identified

Customers may experience the creation of duplicate profiles with new identities for those who have been previously seen. We are collaborating with our vendor to identify and test a potential solution for one of the underlying data storage systems.
Posted Nov 07, 2025 - 21:34 UTC

Investigating

We are investigating the problem with identity resolution in EMEA.
Posted Nov 07, 2025 - 12:30 UTC
This incident affected: Optimizely Data Platform - EMEA Region (Data Ingestion and Processing, Core App Experiences).