Search & Navigation - USEA01 Intermittent Performance Issue

Incident Report for Optimizely Service

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 08:04 UTC

Monitoring

The service has been restored and we're closely monitoring the service health.
Posted Oct 10, 2025 - 07:06 UTC

Investigating

We are currently investigating an event that is intermittently impacting performance on the Search & Navigation service in the US region, [USEA01]. A subset of clients will be experiencing high latency or failed requests.
We will post additional updates hourly or when we have information available. Thank you for your patience.
Posted Oct 10, 2025 - 06:24 UTC
This incident affected: Search and Navigation - NA Region (US East).