PIM background jobs stalling

Incident Report for Optimizely Service

Resolved

This incident has been resolved and service has been restored to full functionality
Posted Apr 16, 2025 - 16:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 10:16 UTC

Update

We are continuing to work on the hotfix for this issue and will provide additional updates as they become available.
Posted Apr 15, 2025 - 19:05 UTC

Update

We've identified a backend bug affecting the Import Asset feature in PIM. In rare cases, jobs with the Overwrite Files option enabled can get stuck and impact overall performance. This is currently limited to a few clients but may affect others due to resource usage. As long as the import job isn’t run, there’s no risk of impact.

We’re testing a hotfix and will provide updates as soon as more information becomes available. Thank you for your patience and understanding.
Posted Apr 15, 2025 - 13:06 UTC

Identified

The issue has been identified and we're working on implementing a fix.
Posted Apr 15, 2025 - 02:54 UTC

Investigating

We are currently investigating an issue causing our background PIM jobs to stall. As a result, some jobs are remaining in the queue for an extended period of time. Our team is actively working on identifying the root cause and implementing a resolution as quickly as possible
Posted Apr 14, 2025 - 20:49 UTC
This incident affected: Configured Commerce: Product Information Management (PIM) – NA Region.