Search & Navigation Incident - Intermittent Slow Performance for EMEA25

Incident Report for Optimizely Service

Resolved

The service remains stable and the incident has been resolved.
Posted Oct 03, 2025 - 08:36 UTC

Monitoring

The service has been restored. We are continuing to monitor for any further issues.
Posted Oct 03, 2025 - 04:24 UTC

Update

We have added additional mitigation measures to enhance stability and are actively monitoring the situation.
Posted Oct 03, 2025 - 03:45 UTC

Update

While we have implemented mitigation measures, the cluster is not yet fully stable. We are closely monitoring the situation and working to address the underlying issues. We appreciate your understanding and will keep you updated. Thank you !
Posted Oct 03, 2025 - 01:53 UTC

Update

We are continuing to work on a fix for this issue. Once the fix has been put in place then we will post another update.
Posted Oct 03, 2025 - 00:20 UTC

Identified

We are currently mitigating an event that is intermittently impacting performance on the Search & Navigation (FIND) service in the EU region, [EMEA25]. A subset of clients may occasionally experience high latency on Search & Navigation operations.
Posted Oct 02, 2025 - 21:14 UTC
This incident affected: Search and Navigation - EMEA Region (North Europe).