Search & Navigation Incident - Intermittent failed request for EMEA25

Incident Report for Optimizely Service

Resolved

This issue has been confirmed resolved.
Posted Oct 02, 2025 - 17:53 UTC

Monitoring

Search & Navigation (FIND) EMEA25 Cluster health has stabilized. We will continue to monitor to ensure continued stability, but services are fully restored at this time.
Posted Oct 02, 2025 - 16:44 UTC

Investigating

We are currently investigating an event that is impacting the availability on the Search & Navigation (FIND) service in the EU region, [EMEA25]. A subset of clients will be experiencing high latency or failed requests.

We will post additional updates hourly or when we have information available. Thank you for your patience.
Posted Oct 02, 2025 - 16:21 UTC
This incident affected: Search and Navigation - EMEA Region (North Europe).