Monitoring - "All Cloudflare services have been restored and are now fully operational. We are moving the incident to Monitoring while we watch platform metrics to confirm sustained stability."
Posted Jun 12, 2025 - 21:03 UTC
Update
Update - Cloudflare services are recovering quickly around the globe. Cloudflare reports that while some services are operational, some residual impact may be seen.
"The core KV service is restored, bringing dependent products back online. We expect further recovery over the next few minutes and a steady drop in impact."
Posted Jun 12, 2025 - 20:42 UTC
Update
Update - Cloudflare’s critical Workers KV service went offline due to an outage of their 3rd party service that is a key dependency. As a result, certain Cloudflare products that rely on KV service to store and disseminate information are unavailable.
Posted Jun 12, 2025 - 20:11 UTC
Identified
Our upstream vendors have reported they have identified the problem and are starting to see services recover. We still expect to see intermittent errors across the impacted services as systems handle retried and caches are filled.
Posted Jun 12, 2025 - 19:53 UTC
Investigating
We are currently investigating reports of a third-party outage affecting DXP and/or Graph services for a subset of customers. We are working closely with the third-party provider to understand and mitigate the impact. We will provide more updates as soon as they become available. Thank you for your patience!
Posted Jun 12, 2025 - 19:06 UTC
This incident affected: Digital Experience Cloud Service - APAC Region (Australia East, Australia Southeast, Japan East, Southeast Asia), Digital Experience Cloud Service - EMEA Region (North Europe, West Europe, Norway East, Sweden Central, UK South, UAE North), Digital Experience Cloud Service - NA Region (Canada East, Canada Central, East US, East US 2, North Central US, West US, West US 2), and Optimizely Graph - APAC Region, Optimizely Graph - EMEA Region, Optimizely Graph - NA Region, Optimizely Graph - UAEN Region.