Multiple reports of "something went wrong" errors in Web UI

Incident Report for Optimizely Service

Resolved

The team has continued monitoring and we have confirmed we have are longer seeing these intermittent errors. Completing this incident as resolved.
Posted May 20, 2025 - 19:41 UTC

Monitoring

The team is reporting we no longer have errors in the UI. The team is reviewing the implementations from today and confirming we are resolved. We will monitor the site and resolve shortly.
Posted May 20, 2025 - 17:41 UTC

Investigating

We are experiencing intermittent "Something went wrong" errors affecting both the Web Experimentation and Feature Experimentation UI.
Posted May 20, 2025 - 16:05 UTC
This incident affected: Feature Experimentation (Application UI) and Web Experimentation (App UI).