Content Recommendations - Degraded performance in North America region

Incident Report for Optimizely Service

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 09:35 UTC

Monitoring

A fix has been implemented and we are monitoring the result.
Posted Jul 23, 2026 - 09:12 UTC

Investigating

We are investigating an issue affecting the Content Recommendations service in the North America region. Users may experience increased latency, delayed recommendation updates, or intermittent failures with search and indexing operations.

We are continuing our investigation and will provide an update as soon as more information becomes available.
Thank you for you patience!
Posted Jul 23, 2026 - 06:57 UTC
This incident affected: Content Recommendations - NA Region (Content Recommendations API, Content Recommendations Management Interface).