Search and Navigation US West - Unstable service performance

Incident Report for Optimizely Service

Resolved

Resolved. No further impacts have been observed, and all systems remain nominal.
Posted Mar 04, 2026 - 17:19 UTC

Monitoring

The issue have been fixed. We identified it was a minor subset of customers impacted. We continue to monitor the service.
Posted Mar 04, 2026 - 14:32 UTC

Identified

We are currently investigating an event that is impacting the availability on the Search & Navigation (FIND) service in the US West region. A subset of clients will be experiencing high latency or 5xx-errors and failed requests.

We will post additional updates hourly or when we have information available. Thank you for your patience.
Posted Mar 04, 2026 - 14:04 UTC
This incident affected: Search and Navigation - NA Region (US West).