Performance issue with CMS Saas in all regions

Incident Report for Optimizely Service

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 09:18 UTC

Update

We are continuing to monitor the health of the service
Posted Nov 21, 2025 - 21:21 UTC

Update

We still continuing to monitor for any further issues. If the situation changes we will provide a new update. Thank you for your patience!
Posted Nov 21, 2025 - 14:54 UTC

Update

We are continuing to monitor for any further issues. Thank you for your patience!
Posted Nov 21, 2025 - 11:50 UTC

Update

We still continuing to monitor for any further issues. If the situation changes we will provide a new update.
Posted Nov 21, 2025 - 10:00 UTC

Update

We are continuing to monitor for any further issues. If the situation changes we will provide a new update.
Posted Nov 21, 2025 - 06:41 UTC

Monitoring

A fix has been implemented and the issue has been mitigated. We will continue to monitor the health of the service.
Posted Nov 20, 2025 - 17:19 UTC

Update

We are continuing to work on a fix for this issue. Thank you for your patience!
Posted Nov 20, 2025 - 15:28 UTC

Identified

The issue has been identified and Engineering team is working on mitigation actions.
Posted Nov 20, 2025 - 14:41 UTC

Investigating

We are currently investigating this issue.
Posted Nov 20, 2025 - 13:41 UTC
This incident affected: CMS SaaS - APAC Region (Australia East), CMS SaaS - EMEA Region (North Europe, UAE North), and CMS SaaS - NA Region (East US, East US 2).