Content Recommendations - Performance Degraded

Incident Report for Optimizely Service

Resolved

Performance has remained steady and healthy. This incident has been resolved.
Posted Oct 27, 2025 - 17:22 UTC

Monitoring

A fix has been implemented by our upstream platform vendor, and we are monitoring the results.
Posted Oct 27, 2025 - 16:02 UTC

Investigating

We are investigating an issue affecting the Content Recommendations service for a subset of customers in the EMEA region, which may cause increased latency in rendering some content, such as serving images. Teams are working to identify a fix as soon as possible.
Posted Oct 27, 2025 - 14:46 UTC
This incident affected: Content Recommendations - EMEA Region (Content Recommendations API).