525 SSL Handshake errors being seen by some customers in Norway

Incident Report for Optimizely Service

Resolved

This incident has been resolved.
Posted Dec 05, 2023 - 08:57 UTC

Monitoring

The issue has been mitigated, and we are closely monitoring the results.
Posted Dec 05, 2023 - 03:38 UTC

Investigating

An issue has developed wherein customers in Norway are experiencing intermittent 525 SSL Handshake errors. We apologize for the inconvenience and thank you for your patience as investigation is underway.
Posted Dec 04, 2023 - 22:07 UTC
This incident affected: Digital Experience Cloud Service - EMEA Region (Norway East).