Search and Navigation - Performance issue with FIND USWE01

Incident Report for Optimizely Service

Resolved

No further issues have been observed while monitoring. This incident has been resolved.
Posted Jul 09, 2025 - 20:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 14:54 UTC

Investigating

We are currently investigating Performance issue with FIND USWE01.
Posted Jul 09, 2025 - 14:00 UTC
This incident affected: Search and Navigation - NA Region (US West).