Configured Commerce - Performance issues

Incident Report for Optimizely Service

Resolved

This incident has been resolved. A fix has been implemented but as previously noted, a redeployment of site code is needed for the fix to be applied. Additional details are provided in the following Optimizely Support Article: https://support.optimizely.com/hc/en-us/articles/35521173909901-Recent-Performance-issues-related-to-Datadog
Posted Apr 03, 2025 - 16:15 UTC

Monitoring

An issue has been identified in a previous version of a third-party monitoring tool used for Configured Commerce platform management, which can cause a very gradual buildup in CPU usage and ultimately result in performance degradation on affected sites.

The fix for this has been implemented by Optimizely Platform Support, but requires a redeployment of site code in order to be applied. Please perform a site redeploy at your earliest convenience to ensure the utilities update has been applied to your site(s).
Posted Apr 02, 2025 - 18:16 UTC
This incident affected: Configured Commerce – APAC Region, Configured Commerce – EMEA Region, and Configured Commerce – NA Region.