The results page for campaigns is not loading for some customers
Incident Report for Optimizely.com
Resolved
Resolved - The results page is now loading as expected. This incident has been resolved.
May 8, 11:56 PDT

Identified - We are aware the results page for campaigns is not loading for some customers. We have investigated the issue, identified a solution and the engineering team is working on the resolution. We will post an update when the issue is resolved. Thank you for your patience.
May 8, 09:21 PDT
Posted May 08, 2020 - 09:21 PDT