Delay in Impression usage number calculation
Incident Report for Optimizely.com
Resolved
All the usage numbers have been backfilled. This incident has now been resolved.
Posted Jun 08, 2020 - 19:42 PDT
Update
We were able to fix our Billing ETL pipeline and are in the process of backfilling the usage numbers.
Posted Jun 08, 2020 - 17:24 PDT
Identified
Our Billing ETL pipeline that calculates Impression Usage numbers is running behind and could be stale by up to 48 hours. No data has been lost and the numbers will be backfilled once we fix our pipeline.

Affected areas:
- Impression Usage number reported in Usage Page
- Impression Usage number reported in /plan API endpoint
- Impression Usage number reported in /usage API endpoint
Posted Jun 08, 2020 - 15:15 PDT
This incident affected: Billing Services.