Issues inviting new collaborators to projects and accounts.
Incident Report for Optimizely.com Status
Resolved
An issue with collaborator invitations was found and fixed. Customers are now able to invite collaborators to their projects and accounts.
Posted 9 days ago. Jan 08, 2018 - 03:41 PST
Identified
Customers are currently unable to invite collaborators to their projects and accounts. We are actively working to fix this issue.
Posted 9 days ago. Jan 08, 2018 - 03:07 PST