Swift and Obj-C SDKs bucketing incorrectly at traffic allocation boundaries
Incident Report for Optimizely.com
Resolved
A bucketing logic issue in the Swift SDK resulting in incorrect experiment and Feature decisions for 1/10000 users was identified impacting versions 3.1.0-3.4.0. A patch version 3.4.1 is available at https://github.com/optimizely/swift-sdk/blob/master/CHANGELOG.md#341

The Obj-C SDK is also affected and the patch version 3.4.1 is available at https://github.com/optimizely/objective-c-sdk/releases/tag/v3.1.4

[Update] 9-25-2020
We have also released an update to our application to ensure that Features with 0% traffic allocation will no longer return “True”, even in the older impacted SDK versions.

To do this we have updated the representation of 0% allocation features in our datafile in a non-breaking fashion. With this application-based fix, no additional action is required at this time to mitigate the issue. We recommend that you upgrade to the new SDK versions at your convenience.
Posted Sep 22, 2020 - 19:47 PDT
This incident affected: Full Stack SDKs.